新人首次安装报错,请大佬看看,谢谢

执行:tiup cluster deploy mytidb 5.4.1 ./topo.yaml --user root -p
报错:
Error: Failed to parse topology file ./topo.yaml (topology.parse_failed)
caused by: yaml: unmarshal errors:
line 4: field user not found in type spec.topology
line 5: field ssh_port not found in type spec.topology
line 6: field deploy_dir not found in type spec.topology
line 7: field data_dir not found in type spec.topology
line 10: field node_exporter_port not found in type spec.topology
line 11: field blackbox_exporter_port not found in type spec.topology
line 13: field tidb not found in type spec.topology
line 14: field log.slow-threshold not found in type spec.topology
line 15: field tikv not found in type spec.topology
line 16: field readpool.storage.use-unified-pool not found in type spec.topology
line 17: field readpool.coprocessor.use-unified-pool not found in type spec.topology
line 18: field pd not found in type spec.topology
line 19: field replication.enable-placement-rules not found in type spec.topology
line 20: field replication.location-labels not found in type spec.topology
line 21: field tiflash not found in type spec.topology
line 22: field logger.level not found in type spec.topology
line 32: field port not found in type spec.topology
line 33: field status_port not found in type spec.topology
line 34: field config not found in type spec.topology
line 35: field server.labels not found in type spec.topology
line 37: field -host not found in type spec.topology
line 48: cannot unmarshal !!map into []*spec.TiFlashSpec
line 51: cannot unmarshal !!map into []*spec.PrometheusSpec
line 54: cannot unmarshal !!map into []*spec.GrafanaSpec

Please check the syntax of your topology file ./topo.yaml and try again.

topo.yaml(语法检验通过):

# Global variables are applied to all deployments and used as the default value of

# the deployments if a specific deployment value is missing.

global:
user: “tidb”
ssh_port: 22
deploy_dir: “/root/tidb-deploy”
data_dir: “/root/tidb-data”

# Monitored variables are applied to all the machines.

monitored:
node_exporter_port: 9100
blackbox_exporter_port: 9115
server_configs:
tidb:
log.slow-threshold: 300
tikv:
readpool.storage.use-unified-pool: false
readpool.coprocessor.use-unified-pool: true
pd:
replication.enable-placement-rules: true
replication.location-labels: [“host”]
tiflash:
logger.level: “info”

pd_servers:

  • host: 192.168.0.102

tidb_servers:

  • host: 192.168.0.102

tikv_servers:

  • host: 192.168.0.102
    port: 20160
    status_port: 20180
    config:
    server.labels: { host: “logic-host-1” }

-host: 192.168.0.102
port:20161
status_port:20181
config:server.labels:{host:“logic-host-2” }

-host:192.168.0.102
port:20162
status_port:20182
config:server.labels:{ host:“logic-host-3” }

tiflash_servers:
-host: 192.168.0.102

monitoring_servers:
-host: 192.168.0.102

grafana_servers:
-host: 192.168.0.102

配置文件格式错了,建议参考文档仔细检查一下。或者发下配置文件截图看下,这个粘贴出来格式变了。

谢谢,已经搞定,第一次使用yaml文件,对齐都是有要求的。

“error”: "failed to scp /root/.tiup/storage/cluster/packages/tidb-v5.4.1-linux-amd64.tar.gz to 192.168.0.102:/root/tidb-deploy/tidb-4000/bin/tidb-v5.4.1-linux-amd64.tar.gz: failed to scp /root/.tiup/storage/cluster/packages/tidb-v5.4.1-linux-amd64.tar.gz to tidb@192.168.0.102:/root/tidb-deploy/tidb-4000/bin/tidb-v5.4.1-linux-amd64.tar.gz

:+1:

我太菜了,还请大佬继续协助下

topo.yaml (1.2 KB)

tiup-cluster-debug-2022-05-13-12-32-31.log (267.7 KB)

大佬还在吗?帮我看看下面的问题吧

手动执行下这个命令看看是否有问题,大概率是互信问题
scp /root/.tiup/storage/cluster/packages/tidb-v5.4.1-linux-amd64.tar.gz to tidb@127.0.0.1:/root/tidb-deploy/tidb-4000/bin/tidb-v5.4.1-linux-amd64.tar.gz

scp: /root/tidb-deploy/tidb-4000/bin/tidb-v5.4.1-linux-amd64.tar.gz: No such file or directory

用这个试试,刚才发错了

可以参考这里试下手动配置下互信
https://docs.pingcap.com/zh/tidb/stable/check-before-deployment#手动配置-ssh-互信及-sudo-免密码

谢谢,我试试

这个问题搞定了,谢谢