TiDB-backend使用报错

tidb 版本4.0.2
配置文件:
[tikv-importer]
backend = “tidb”
on-duplicate = “ignore”
[lightning]
level = “info”
file = “tidb-lightning.log”
pprof-port = 8289
[checkpoint]
enable = true
schema = “tidb_lightning_checkpoint”
[tidb]
host = “10.32.3.75”
user = “root”
password = “*********”
port = 4000
#max-allowed-packet = 134217728
status-port = 10080

[mydumper]
data-source-dir = “/tools/backup”

[[routes]]
#Table routes
pattern-schema = “frxs_trade_area_1”
pattern-table = “t_trade_order_area_*”
target-schema = “frxs_trade_area_1”
target-table = “t_trade_order_area_new”

启动命令:tidb-lightning -c=/data/tidb-tools/area-config.toml
报错提示:
tidb lightning encountered error: config file contained unknown configuration options: routes.pattern-schema, routes.pattern-table

工具版本:tidb-toolkit-v4.0.2-linux-amd64.tar.gz

你好,

添加 lightning_server 标签看下是否可以

[lightning_server]
192.168.20.10

你好 使用TIDB-backend还需要配置专门的lightning_server是吧

tidb-backend 模式不需要配置 importer servers,但是需要配置 lightning server 的。
可以在看下文档,有相关说明哦~

你那边可以贴一份标准的tidb-backend 文件给我看下吗

包含routes规则的配置

#[[routes]]

Table routes

#pattern-schema = “frxs_trade_area_1”
#pattern-table = “t_trade_order_area_*”
#target-schema = “frxs_trade_area_1”
#target-table = “t_trade_order_area_new” 刚才确认了下 把这个去掉就可以正常执行了 这个文档说明有问题 麻烦确认下

完整配置文件如下:

route 的配置是 schema-patterntable-pattern, 看起来你这个配置里面这两项的名字反了

@glorvs 官方文档问题,已修改,github 是对的,