[FAQ] ansible 安装报错 Failed to parse inventory.ini with ini plugin unable to parse no inventory was parsed

[问题澄清]

ansible 安装过程中报错 Failed to parse inventory.ini with ini plugin unable to parse as an inventory source,完整报错如下:

[原因分析]

inventory.ini 文件修改错误,[] 缺少了一半 ] ,参数格式不正确

[解决方案]

修改前备份 inventory.ini 文件 参考修改,或者参考链接(注意是 3.0.14,可以选择对应版本,新版本推进使用 tiup 安装)

https://github.com/pingcap/tidb-ansible/blob/v3.0.14/inventory.ini

[参考案例]