TiDB 4.0 使用 TiUP 修改 原tidb 3.0.x config/tidb.yml 配置文件

[tidb@test1 ~]$ tiup cluster list
Starting /home/tidb/.tiup/components/cluster/v0.4.6/cluster list
Name      User  Version    Path                                                PrivateKey
----      ----  -------    ----                                                ----------
tidb-dev  tidb  v4.0.0-rc  /home/tidb/.tiup/storage/cluster/clusters/tidb-dev  /home/tidb/.tiup/storage/cluster/clusters/tidb-dev/ssh/id_rsa
[tidb@test1 ~]$

[tidb@test1 ~]$ tiup cluster edit-config tidb-dev
global:
  user: tidb
  ssh_port: 22
  deploy_dir: /home/tidb/tidb-deploy
  data_dir: /home/tidb/tidb-data

monitored:
  node_exporter_port: 9100
  blackbox_exporter_port: 9115
  deploy_dir: /home/tidb/tidb-deploy/monitored-9100
  data_dir: /home/tidb/tidb-data/monitored-9100
  log_dir: /home/tidb/tidb-deploy/monitored-9100/log

server_configs:
  tidb:
    binlog.enable: false
    binlog.ignore-error: false
    log.level: warn
    log.slow-threshold: 300
    # 用于处理v3.0.7和以前版本升级中的兼容性问题(为了兼容联合索引长度超长的问题,原(3072) 这里改为4倍)
    max-index-length: 12288
    # 开启支持大小写不敏感, 只有在集群初始化时配置才生效, 默认 false
    new_collations_enabled_on_first_bootstrap: true

  tikv:
    readpool.coprocessor.use-unified-pool: true
    readpool.storage.use-unified-pool: true

  pd:
    replication.enable-placement-rules: true
    schedule.leader-schedule-limit: 4
    schedule.region-schedule-limit: 2048
    schedule.replica-schedule-limit: 64
  tiflash: {}
  tiflash-learner: {}
  pump: {}
  drainer: {}
tidb_servers:
...................下面省略
[tidb@test1 ~]$
重新加载配置文件

tiup cluster reload tidb-dev -N ip:port

[tidb@test1 ~]$ tiup cluster reload tidb-dev -N 172.18.80.7:4000
1赞

PS:

-N ip:port

-R tidb,tikv

1赞