使用ansible升级到v4.0.0rc报错

原来的版本是V3.0.0 image

您好,

  1. numactl 需要手动安装下,可以尝试使用 yum install -y numactl 解决。

  2. 推荐使用 tiup cluster import --help 导入 ansible 环境之后升级到 4.0.0-rc

这个有文档没tiup导入ansible image 我执行这个让我先安装一个集群,我已经有ansible管理的集群了,不想安装

您好,

  1. 如果继续使用 ansible,升级步骤和方式和以前的升级方式是一样的。

  2. 目前 4.0.0-rc 的安装文档已发到官网,可以看下,未来 ansible 可能不在维护,建议迁移至 tiup cluster 进行维护,有任何问题随时联系我们: https://pingcap.com/docs-cn/stable/how-to/deploy/orchestrated/tiup/

问下出现此报错的操作流程是什么?

这个问题在最新版本的 v4.0.0 rc 已经修复了。麻烦重新下载一下。另外更推荐使用 tiup 来管理集群。

早上刚刚安装的v4.0.0 rc,也是报这个错误

我正在试,估计又提交代码了,我看releses是29分钟前

我刚刚建立好配置文件。。。

成功了

官网上有没有将现有ansible集群迁移到tiup管理的操作说明?

tiup 相关使用方法以及迁移方法可以参考上面的链接 :

先使用 tiup install cluster 添加 cluster 组件,然后可以使用 tiup help cluster 查看 cluster 的帮助