滚动升级错误

为提高效率,提问时请提供以下信息,问题描述清晰可优先响应。

  • 【TiDB 版本】:3.0.3升级3.0.11
  • 【问题描述】:按照官网教程升级,遇到如下错误 [10.16.4.94]: Ansible FAILED! => playbook: rolling_update.yml; TASK: check_config_pd : Check result; message: {“changed”: false, “msg”: “PD config error”} 配置文件和日志见附件 inventory.ini (1.8 KB) hosts.ini (191 字节) ansible.log (93.5 KB) fail.log (155 字节)

操作步骤

git clone -b v3.0.11 https://github.com/pingcap/tidb-ansible.git tidb-ansible-v3.0.11

cp /home/tidb/tidb-ansible/hosts.ini /home/tidb/tidb-ansible-v3.0.11/hosts.ini

cp /home/tidb/tidb-ansible/inventory.ini /home/tidb/tidb-ansible-v3.0.11/inventory.ini

cp /home/tidb/tidb-ansible/bootstrap.yml /home/tidb/tidb-ansible-v3.0.11/bootstrap.yml

cp /home/tidb/tidb-ansible/roles/check_system_dynamic/tasks/main.yml /home/tidb/tidb-ansible-v3.0.11/roles/check_system_dynamic/tasks/main.yml

cp /home/tidb/tidb-ansible/roles/tikv/tasks/check_filesystem.yml /home/tidb/tidb-ansible-v3.0.11/roles/tikv/tasks/check_filesystem.yml

ansible-playbook local_prepare.yml

ansible-playbook rolling_update.yml

即得到上述报错

若提问为性能优化、故障排查类问题,请下载脚本运行。终端输出的打印结果,请务必全选并复制粘贴上传。

您好, 原则上不建议 copy 旧版本 inventory 文件,由于版本升级会导致配置文件可能存在不同。 建议重新下载并编辑 inventory 文件。

image

请严格执行文档中的升级操作步骤