DM不支持MySQL8?

为提高效率,提问时请提供以下信息,问题描述清晰可优先响应。

  • 【TiDB 版本】:3.0.9
  • 【问题描述】:我们的源MySQL使用的是8.0.19的版本,在使用DM进行数据同步在校验的时候报mysql版本太高,无法迁移数据,MySQL版本低于8.0是必须的吗? 什么时候能支持8.0及以上版本?

image

若提问为性能优化、故障排查类问题,请下载脚本运行。终端输出的打印结果,请务必全选并复制粘贴上传。

您好, 在使用 DM 工具之前,需了解以下限制: 数据库版本 5.5 < MySQL 版本 < 8.0 MariaDB 版本 >= 10.1.2 注意: 如果上游 MySQL/MariaDB server 间构成主从复制结构,则需要 5.7.1 <MySQL 版本 < 8.0 或者 MariaDB 版本>= 10.1.3

详细文档请看链接: