tispark 版本对照

文档不清晰或不完整

文档新增需求

  • 需求类型:新增文档
  • 需求背景:tidb 的版本,spark的版本,以及 tispark 的版本都有很多,github上描述的对照不够详细,在开发层面缺少 关键组件 引入的版本对照
  • 期望增加 tispark 版本对照表 以及 tispark组件版本引入 文档,加到现有文档组件引入的位置

有一些用户实践的文章也挺好的,希望在2022年元旦之后,有更多的好文出现

这是你说的版本对照表么?
image

还缺 tispark-assembly 的版本对照…

哪儿翻出来的…


实际上tispark打包出来就是tispark-assembly,只有这一个jar包,这个图里面,TiSpark Version是不是就是tispark-assembly的版本

还是等官方确认下吧,而且哪个地方确实要改下…

看了一下贴的两个报错的地方,都是把 assembly 包打进了 spring jar 包里,作为主 jar 包的依赖引入。
这样的方式似乎导致了class not found ,单独引入 assembly 的使用方式应该不会有类似问题

这个描述不太对阿,maven 本身对于依赖会有相应的一些关联提示,还是等官方提供相应的一些指导把

你是不是用的tispark的master分支,用的spark3.0.x版本?我在上述场景下遇到了相似的问题。

spring和tipspark打包在一起,是什么场景下的?

收到~我反馈一下~