TiDB 2.1.1 部署报错

为提高效率,提问时请提供以下信息,问题描述清晰可优先响应。

  • 【TiDB 版本】:v2.1.1
  • 【问题描述】:
{"changed": true, "cmd": "cp -v /home/tidb/tidb-ansible/downloads/core/target/tispark-core-*-SNAPSHOT-jar-with-dependencies.jar \"/home/tidb/tidb-ansible/resources/bin/tispark-SNAPSHOT-jar-with-dependencies.jar\"", "delta": "0:00:00.035115", "end": "2020-02-14 21:39:19.811597", "msg": "non-zero return code", "rc": 1, "start": "2020-02-14 21:39:19.776482", "stderr": "cp: cannot stat '/home/tidb/tidb-ansible/downloads/core/target/tispark-core-*-SNAPSHOT-jar-with-dependencies.jar': No such file or directory", "stderr_lines": ["cp: cannot stat '/home/tidb/tidb-ansible/downloads/core/target/tispark-core-*-SNAPSHOT-jar-with-dependencies.jar': No such file or directory"], "stdout": "", "stdout_lines": []}


部署TiDB v2.1.1 失败

执行到的步骤是

ansible-playbook local_prepare.yml

麻烦确认下目录的权限。

可以使用 chown -R tidb:tidb tidb-ansible 来变更文件夹的权限。


你好,变更文件夹权限试过 不行,原本就是tidb用户,到目录去看了下 发现tispark-core这个包并没有下载下来

嗯,这边比较奇怪,麻烦尝试下用 2.1 的最新 release 版本来尝试下载一下?

  • 部署这个版本是为了在测试集群上测试搭建TiDB Binlog, 已经通过打包正式服的中控机,再上传到测试服解决了该问题。
  • 测试服上没有多余的磁盘格式化成 ext4 nodelalloc option ,可以通过设置参数让其成功部署吗
  • 只为了验证功能
Ansible FAILED! => playbook: deploy.yml; TASK: tikv : Preflight check - Does tikv data dir meet ext4 file system requirement; message: {"changed": false, "msg": "You don't mount the file system of /usr/local/datadisk with ext4 nodelalloc option. See https://github.com/pingcap/docs/blob/master/op-guide/ansible-deployment.md#mount-the-data-disk-ext4-filesystem-with-options."}

可以的,找到相关的 /roles/tikv/tasks/check_filesystem.yml 修改就可以。

好的 谢谢

如果问题已经解决,请标记最佳解决方案。如果有新的问题,需要单独创建新的 asktug 问题。

我的磁盘是ext4但是没有nodelalloc,要怎么改配置啊??这样对后面的数据库有没有什么影响啊??

目前该条件是需要配置的,建议按照官网操作软硬件环境达标再进行集群部署。https://pingcap.com/docs-cn/stable/how-to/deploy/orchestrated/ansible/