升级3.0NTP报错

目前打算升级3.0版本,ansible-playbook excessive_rolling_update.yml执行命令报NTP错误

时间都是一致的,sudo ntp也可以进行同步

ntpstat也可以看到同步信息image

麻烦提供下 tidb-ansible 的版本。

tidb_version = v3.0.5

执行下 ntpstat | grep -w synchronised | wc -l 看下返回结果

结果为1

是在 Ansible 对应报错的机器上面运行吗?

我现在把时间同步关掉了,现在报PD错误

12是好的,怎么报12错误?

这里不是指的 12 这台机器的 PD 有问题。只不过是 curl http://172:2379/pd/health 的发现有 PD node 是有问题的。

解决步骤呢?

麻烦给下问题 PD 节点的日志

172机器的吗?

不健康的节点,另外问问旧版本集群的状态是正常的吗?原来是什么版本的?

原来是2.1版本,升级之前是正常的

这个是8月份的日志。现在175 的这个节点的 PD 服务已经没有启动的是吧?有没有最新的日志呢? 另外请问使用的是2.1的哪一个小版本呢?

正在进行下一步,目前没有发现问题