k8s 部署 TiDB,无法设置 txn-entry-size-limit 配置,大佬们来看看

【 TiDB 使用环境】
【背景】:业务需要使用导入blob类型数据,超过6M,报错:entry too large, the max entry size is 6291456,xxx
【现象】:无法配置txn-entry-size-limit
【问题】:无论在yaml中怎么设置tidb的config,但tidb启动后进入容器查看tidb.toml,发现不会出现此配置,所以依旧会entry too large,但是我放其他配置,都没问题,都能出现,我的版本是5.0.1
【业务影响】:有张表无法导入
【TiDB 版本】:5.0.1
【TiDB Operator 版本】:v1.1.10
【K8s 版本】:


【附件】:

apiVersion: pingcap.com/v1alpha1
kind: TidbCluster
metadata:
  name: mdm
spec:
  version: v5.0.1
  timezone: UTC
  pvReclaimPolicy: Retain
  enableDynamicConfiguration: true
  configUpdateStrategy: RollingUpdate
  discovery: {}
  pd:
    baseImage: pingcap/pd
    replicas: 1
    # if storageClassName is not set, the default Storage Class of the Kubernetes cluster will be used
    storageClassName: xxx
    requests:
      storage: "20Gi"
    config: {}
  tikv:
    baseImage: pingcap/tikv
    replicas: 1
    # if storageClassName is not set, the default Storage Class of the Kubernetes cluster will be used
    storageClassName: xxx
    requests:
      storage: "50Gi"
    config:
      storage:
        # In basic examples, we set this to avoid using too much storage.
        reserve-space: "5GB"
      rocksdb:
        # In basic examples, we set this to avoid the following error in some Kubernetes clusters:
        # "the maximum number of open file descriptors is too small, got 1024, expect greater or equal to 82920"
        max-open-files: 10240
      raftdb:
        max-open-files: 10240
      raftstore:
        raft-entry-max-size: 120MB
    additionalVolumeMounts:
    - name: nfs
      mountPath: /dbBackup
  tidb:
    baseImage: pingcap/tidb
    replicas: 1
    service:
      type: ClusterIP
    config: 
      performance:
        txn-total-size-limit: 1073741824
        txn-entry-size-limit: 62914560
        max-txn-ttl: 5600000
      log:
        enable-slow-log: false
# kubectl exec -it mdm-tidb-0 -c tidb sh -n tidb-cluster -c tidb
kubectl exec [POD] [COMMAND] is DEPRECATED and will be removed in a future version. Use kubectl exec [POD] -- [COMMAND] instead.
/ # cat /etc/tidb/tidb.toml
[log]
  enable-slow-log = false
  [log.file]
    max-backups = 3

[performance]
  max-txn-ttl = 5600000
  txn-total-size-limit = 1073741824
4 Likes

1 Like

Hi ~ 现在状态是没有生效对吗?通过 TiDB log 确认过参数吗?

您好,想请问此问题后续是如何解决呢? 我yaml config写法与楼主大体相同,也同样遇到 txn-entry-size-limit 无法更新上去的问题,但其他配置都有成功更新 (版本为 5.1.0)

你好~麻烦重新发一个帖子~

此话题已在最后回复的 1 分钟后被自动关闭。不再允许新回复。