TiDB 4.0.1 store mode 如何变为 auto

TiDB版本v4.0.1,我调整了一下 rate 由 15 变为了30,发现mode 也从 auto 变成了 manual,然后我又调回去,发现mode没有变成 auto,请问如何在 4.0.1 上设置 mode 为 auto

调整前:
» store limit
{
“1”: {
“rate”: 15,
“mode”: “auto”
},

» store limit
{
“1”: {
“rate”: 15,
“mode”: “manual”
},

1 Like

通过什么方式修改的?

1 Like

截个图看看吧,我用6.0.0和4.0.0都没能复现

1 Like

store limit all 30

1 Like

执行了 store limit all 30 后,下面的 mode 会变为 manual

1 Like

感觉你的版本不是4.0的,我 4.0.8的版本输出跟你不一样,不过你这个设置影响不大,是临时的,切换 leader 或者 PD 重启后会被重置。

参考:https://docs.pingcap.com/zh/tidb/v4.0/configure-store-limit

image

1 Like

这个应该是你自行操作修改了 store-limit-mode 吧 ? 建议你自行排查下操作日志,另外 mode 修改为 auto 在 一直是一个实验性功能。
image

而且修改 store-limit-mode 会有一个 bug,详细可以看下这个 issue https://github.com/tikv/pd/pull/2544

1 Like

请问,config show 里面的 store-limit-mode 与 store limit 里面的 mode 是一回事儿么?

1 Like

4.0.8 store limit 确实和 4.0.1 的不一样

1 Like

我用4.0.1测试了下,不手动设置限速的话store limit返回{},手动设置后会变成manual,这个应该是预期的,可以用config set store-limit-mode auto手动把store-limit-mode调整为auto

1 Like

是,参考下官网吧。https://docs.pingcap.com/zh/tidb/stable/pd-control#config-show--set-option-value--placement-rules

1 Like

千万不要这么做

1 Like

没事,测试环境,随便玩, auto模式还是实验特性:rofl:

1 Like

参考官方文档吧

此话题已在最后回复的 1 分钟后被自动关闭。不再允许新回复。