Mydumper数据迁移

tidb 集群是什么版本的,建议使用 2.1.16 或 3.0.2 版本,导入时可以将 -t 设置为 1 试试

官网下载ansible安装最新版本

你这测试环境比我的要好很多,我就三台测试机器,tidb pd tikv, 我都装一起了也没出现你这样的问题啊。

我们的开发环境和你的配置一样,问题很少

你的上游数据库是什么 版本的? MariaDB 还是 MySQL

我们是测试完了,就上线一部分业务了。使用ansible安装的,在控制台转了一个连接数据库的客户端 centos7 安装mysql,实际是maridb

你用的是 TiDB v4.0.0 啊 我用的是 3.0.2 image

怎么看版本,我是ansible安装的

用稳定版的吧

看你发的截图还是 4.0 版本,现在这个版本还在开发阶段不稳定,ansible 部署时也不要用最新版本,而是指定版本分支或 tag,如 git clone -b v2.1.6 https://github.com/pingcap/tidb-ansible.git

官网下载的,直接就是4.0版本,哎,弄了好几天了,原来是这个问题 ,线上用v2.1.6版本吗,不是现在都是3.几版本以上了吗,还是直接用3.几以上版本呢,我这个集群环境可以销毁吧

嗯嗯 之前官网下载的时候,没有注意版本,我销毁集权重新装吧。多谢啦

用 v3.0.2的, $ git clone -b v3.0.2 https://github.com/pingcap/tidb-ansible.git

太感谢你啦 多谢多谢 我直接用你这个链接下载就可以的吧

嗯呢,直接用吧,不客气

我在完是这个版本,对吗

我是安装官网滚动升级的那个做的

image

嗯嗯 装好了 这个ansible 2.7.11 也是3.0.2版本的